Back to Mobile View

Skip to Content

Fusion 4.1 support for pre-Lion, non-server OS X is a mistake, says VMware

Late on Friday, Macworld's Jason Snell discovered that the new 4.1 version of virtualization tool VMware Fusion had a special talent. Up until 4.1, Fusion would refuse to install non-server versions of Snow Leopard and Leopard into a virtual machine, since Apple's licensing for those OS builds did not include a virtualization option. Only the server versions of 10.5 and 10.6 were legit for VM use; for 10.7, Apple moved to allow virtualization of either client or server.

In the new Fusion build, however, client versions of 10.6 and 10.5 are OK for installation in a new VM; the install tool just prompts you to make sure you're license-compliant.

While a Lion virtual machine is pretty useful, a Snow Leopard VM has something Lion doesn't have: the Rosetta PPC compatibility option, letting users run older applications that rely on PowerPC code. For some apps (Quicken Deluxe being the primary example), that's a workable way to keep them compatible for the time being.

It wasn't clear from the Fusion 4.1 release notes whether VMware had sought Apple's permission to make this adjustment to the install process, and I asked the Fusion team for comment. Earlier this evening, in a blog post, the company announced that the licensing check for Leopard Server and Snow Leopard Server (the only legitimately virtualizable versions of 10.5 or 10.6) was left out of the 4.1 build of Fusion. A subsequent update is likely to restore the checking routines that prevent the installation of non-server 10.5 and 10.6 OS versions.

In the meantime, Fusion 4.1 remains a downloadable update for the virtualization app, which normally retails for $79.99 but is currently on sale for $49.99. A 30-day demo download is also available.

© 2014 AOL Inc. All Rights Reserved.